Preparing for Wordpress 5.0

Gutenberg vs Classic Press

Wordpress 5.0 has to be the least welcome update to the classic content management system for over a decade. As most people know, the new version will include the hideous Gutenberg editor, replacing the classic page and post editor. The old adage says “If it ain't broke, don't fix it.” The classic editor ain't broke.

For that reason, a number of Wordpress users have forked the application (as they have every right to do, because it is open source software). They are putting together an application called ClassicPress, which will be compatible with the current version of Wordpress (4.9.8), but will be developed and updated separately. It may take time before I am able to migrate my sites to using ClassicPress, so in the meantime this is what will happen:

Wordpress have released a plugin to maintain the classic page editor for a limited period. All my sites will use this plugin, until such time as I can migrate to ClassicPress. You will notice no change whatsoever to the front end of your sites.

Leave a Reply

Your email address will not be published. Required fields are marked *

*